[erlang-questions] Strange interaction between Docker and Erlangs ports (exit_status lost)

André Cruz andre@REDACTED
Thu Dec 17 12:43:37 CET 2015

On 17 Dec 2015, at 00:59, Nathaniel Waisbrot <nathaniel@REDACTED> wrote:
> Does adding a `-t` flag to `docker run` (to give it a TTY) make any difference?

No difference.

> How long have you tried waiting? If it hangs forever, use `docker exec` to connect to the container and see if it's executing. Better: use `touch` instead of `ls` and then you can see if the process has run and exited.

The "exit_status" message never arrives. I've waited 1 day. :) The external command has run and finished, I can ssh into the machine and see that. The external process is defunct (zombie). However, the port still seems to be active on the beam vm, at least from what I could gather from the "proc info". It seems the beam vm is not aware the program finished, does it use SIGCHLD?

Can this be related? http://erlang.org/pipermail/erlang-questions/2015-October/086590.html If the processes are put in different process sessions can the parent not receive the signal?

> Have you tried other commands? How about `echo`?

No change.

> Have you tried giving a full path (`/bin/ls`)?

No change.


More information about the erlang-questions mailing list