[erlang-questions] Strange interaction between Docker and Erlangs ports (exit_status lost)

Nathaniel Waisbrot nathaniel@REDACTED
Thu Dec 17 01:59:20 CET 2015

Does adding a `-t` flag to `docker run` (to give it a TTY) make any
How long have you tried waiting? If it hangs forever, use `docker exec` to
connect to the container and see if it's executing. Better: use `touch`
instead of `ls` and then you can see if the process has run and exited.
Have you tried other commands? How about `echo`?
Have you tried giving a full path (`/bin/ls`)?

On Wed, Dec 16, 2015 at 6:47 AM, André Cruz <andre@REDACTED> wrote:

> Hello.
> I've run into a strange problem when using Erlang and Docker. I have a
> small PoC that uses open_port to launch an "ls" command and, under normal
> circumstances, I get the exit_status message and the program terminates.
> However, if I run the command directly via "docker run", it seems the
> message is lost. The "ls" command is executed and terminates, but I don't
> get the "exit_status" message.
> This issue seems related to an old message to the list:
> http://erlang.org/pipermail/erlang-questions/2013-September/075385.html
> The relevant code and Dockerfile can be found here:
> https://github.com/edevil/docker-erlang-bug
> The built image: https://hub.docker.com/r/edevil/docker-erlang-bug/
> Docker issue:
> https://github.com/docker/docker/issues/8910#issuecomment-165072444
> Now, I don't even know if this is a Docker issue, or an Erlang issue, or
> neither. Can someone shed some light on this issue?
> Thank you and best regards,
> André Cruz
> _______________________________________________
> erlang-questions mailing list
> erlang-questions@REDACTED
> http://erlang.org/mailman/listinfo/erlang-questions
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20151216/b3b0e10c/attachment.htm>

More information about the erlang-questions mailing list