[erlang-questions] Simple SFTP Server

Anthony Esposito tony.m.esposito@REDACTED
Tue Nov 24 01:41:36 CET 2015

Hi all,

I'm trying to setup a simple Erlang SFTP server based on the documentation
example from here: http://www.erlang.org/doc/apps/ssh/using_ssh.html#id59641

I'm struggling with it as my ssh client will only report "no hostkey alg"
no matter how I configure the server. I've setup some public keys in a
/tmp/ssh folder and tried the following code:

ssh:daemon(8989, [{system_dir, "/tmp/ssh"},
{user_dir, "/tmp/ssh"},
{subsystems, [ssh_sftpd:subsystem_spec([{cwd, "/tmp/ssh"}])

I've both placed the keys in a .ssh folder and in the primary folder. I've
experimented with different permissions and filenames but I'm not sure what
the actual issue is.

I've also tried forcing an algorithm with my client.

sftp -oPort=8989 -o IdentityFile=/tmp/ssh/host_key -o 'HostKeyAlgorithms
ssh-rsa,ssh-dss' localhost

I'm trying to do this in userspace.

If anyone has already figured this out I'd appreciate some tips to get me
past this.

Thank you,
Anthony Esposito
github/twitter: tesp0
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20151124/b713a0fd/attachment.htm>

More information about the erlang-questions mailing list