[erlang-questions] Cannot build a work vm on FreeBSD with dtrace AND enable dirty-schedulers

Steve Vinoski vinoski@REDACTED
Fri Apr 11 15:39:14 CEST 2014

On Fri, Apr 11, 2014 at 12:30 AM, Wu Ray <mjollnir.ray@REDACTED> wrote:

> Hi, list
> I cannot build a working erlang 17 on FreeBSD 10.0, with dtrace AND
> enabled dirty-schedulers at the same time, that's my steps:
> ./configure --with-dynamic-trace=dtrace --enable-dirty-schedulers
> gmake
> then, the build erl vm just quit with:
> Segmentation fault(core dumped)
> I've tried gcc47, same result.
> CC=gcc47 CXX=g++47 ./configure --with-dynamic-trace=dtrace
> --enable-dirty-schedulers
> if I build with-dtrace OR enable dirty-schedulers separately, the VMs run
> well.
> but the dirty-schedulers number looks strange:
> Erlang/OTP 17 [erts-6.0] [source] [64-bit]
> [ds:10:5851653:18446744073709551611] [async-threads:38554976] [hipe]
> [kernel-poll:]
> Eshell V6.0 (abort with ^G)
> 1> erlang:system_info(dirty_cpu_schedulers).
> ** exception error: bad argument
>      in function  erlang:system_info/1
>         called as erlang:system_info(dirty_cpu_schedulers)
> And, gcc48 cannot build a working VM with enabled dirty-schedulers, the vm
> quit with Segmentation fault.
> BTW: my FreeBSD 10.0 is running in VirtualBox 4.3.10 on Ubuntu13.10

I'm currently running Erlang 17.0 with both dtrace support and dirty
scheduler support on OS X 10.8, so I'm guessing this problem is specific to

Notice your async thread count is wrong as well. If you build without
dtrace and without dirty schedulers, what is the async thread count?

I'll try to get FreeBSD 10.0 running in a VM to see if I can duplicate the

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20140411/f9f2481a/attachment.htm>

More information about the erlang-questions mailing list