[erlang-questions] Cannot build a work vm on FreeBSD with dtrace AND enable dirty-schedulers

Wu Ray mjollnir.ray@REDACTED
Fri Apr 11 06:30:02 CEST 2014

Hi, list

I cannot build a working erlang 17 on FreeBSD 10.0, with dtrace AND enabled
dirty-schedulers at the same time, that's my steps:
./configure --with-dynamic-trace=dtrace --enable-dirty-schedulers

then, the build erl vm just quit with:
Segmentation fault(core dumped)

I've tried gcc47, same result.
CC=gcc47 CXX=g++47 ./configure --with-dynamic-trace=dtrace

if I build with-dtrace OR enable dirty-schedulers separately, the VMs run
but the dirty-schedulers number looks strange:

Erlang/OTP 17 [erts-6.0] [source] [64-bit]
[ds:10:5851653:18446744073709551611] [async-threads:38554976] [hipe]

Eshell V6.0 (abort with ^G)
1> erlang:system_info(dirty_cpu_schedulers).
** exception error: bad argument
     in function  erlang:system_info/1
        called as erlang:system_info(dirty_cpu_schedulers)

And, gcc48 cannot build a working VM with enabled dirty-schedulers, the vm
quit with Segmentation fault.

BTW: my FreeBSD 10.0 is running in VirtualBox 4.3.10 on Ubuntu13.10

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20140411/3034693d/attachment.htm>

More information about the erlang-questions mailing list