[erlang-questions] Getting started with Cowboy and then?

Thu Apr 10 00:58:50 CEST 2014

Many thanks, Mike, for the detailed and thoughtful response. I'll give it ago.

Best wishes,


-----Original Message-----
From: "Mike Oxford" <moxford@REDACTED>
Sent: Wednesday, April 9, 2014 5:59pm
To: lloyd@REDACTED
Cc: "Erlang Questions" <erlang-questions@REDACTED>
Subject: Re: [erlang-questions] Getting started with Cowboy and then?

When you run git, it creates a hidden ".git" directory which is not
normally visible.  Inside the .git/config file is the repo you cloned from,
called the upstream.

Nuke the .git directory completely.
Move stuff around
git init your own repo once you're done reorganizing.  You can then set the
upstream to your own github if needed later.

or the more difficult route: modify the .git/config file directly
(vi/emacs) or reset the upstream via `git remote` calls.

When you rename the project, you'll need to update your Makefile with the
correct project name.  I am not sure if erlang.mk does directory traversals
or if you'll need to tell it where the new src file is.  Commonly you'll
see a top-level Makefile calling sub-Makefiles, one for each project.



On Wed, Apr 9, 2014 at 1:56 PM, <lloyd@REDACTED> wrote:

> Hello,
> If it's not one thing, it's another.
> Attempting to deepen my understanding of Cowboy, I went back to Getting
> Started.  First time through it worked like a charm. Then I renamed the app
> and tried to rearrange directories a bit to support multiple applications:
> From:
> hello_erlang
>    erlang.mk
>    Makefile
>    relx.config
>    src
> To:
> lit
>    apps
>      lit
>         src
>    erlang.mk
>    Makefile
>    relx.config
> Now make gave me an error:
> ...
> Cloning into '/home/lloyd/Erl/Cowboy/lit/deps/cowboy'...
> fatal: https://github.com/extend/cowboy/info/refs not found: did you run
> git update-server-info on the server?
> make: *** [/home/lloyd/Erl/Cowboy/lit1/deps/cowboy] Error 128
> So... started all over again from scratch in a new directory, following
> Getting Started explicitly. But now, I get the same error; e.g. worked the
> first time, but not the second.
> Google suggests that I might need to update git. But I'm running git
> version; and the github site suggests that all above 1.7.10 should
> be stable.
> Three questions:
> 1) Why would make work the first time around, but not the second?
> 2) How can I fix it?
> 3) What else do I need to do, in Makefile for instance, to successfully
> compile my new directory organization?
> Many thanks,
> *********************************************
> My books:
> http://thegospelofashes.com
> Strength is not enough. Do they have the courage
> and the cunning? Can they survive long enough to
> save the lives of millions?
> http://freeinpancho.com
> A community of misfits help a troubled boy find his way
> http://ayatakeo.com
> Star-crossed love, war and power in an alternative
> universe
> Available through Amazon or by request from your
> favorite bookstore
> **********************************************
> _______________________________________________
> erlang-questions mailing list
> erlang-questions@REDACTED
> http://erlang.org/mailman/listinfo/erlang-questions

More information about the erlang-questions mailing list