[erlang-questions] Compiling R14B03 with hipe on Ubuntu

Michael Schreckenbauer grimlog@REDACTED
Sat Sep 10 17:49:57 CEST 2011

Hi Ahmet,

On Saturday, 10. September 2011 11:20:53 Ahmet Nalcacioglu wrote:
> I have a 64 bit ubuntu 10.10
> I tried everything to build erlang with hipe support, to no avail.
> I tried using kerl
> KERL_CONFIGURE_OPTIONS="--enable-hipe" kerl build R14B03 r14b03_hipe
> Then I tried on a source I dowloaded using
> ./configure --enable-hipe
> I even removed the following lines in otp_build script which disables
> hipe for linux
> "
> if target_contains linux; then
> XX=`echo $* | grep -v able-hipe`
> if [ "$*" = "$XX" ]; then
> CONFIG_FLAGS="$CONFIG_FLAGS --disable-hipe"
> fi
> fi
> "

you are misreading that script.
It adds --disable-hipe, if there's no explicit --enable-hipe or --disable-hipe 
given to ./configure
XX is *empty*, if there's something containing "able-hipe" on the commandline, 
so it *differs* from "$*", so nothing is added to CONFIG_FLAGS.
If there is nothing on the commandline matching "able-hipe", then XX is the 
given commandline, so it matches "$*" and "--disable-hipe" get's added.

> then do a ./configure --enable-hipe
> I can't get a build with hipe enabled. I don't understand why for
> linux hipe is disabled in the first place.
> The only way I can get a hipe enabled erl is through ubuntu software
> center, which has a erlang-base-hipe module. However that is an old
> build R13.
> Can anyone help me? I tried but I don't know why simply ./configure
> --enable-hipe does not work.

What's the exact error you are getting?
It works for me (I use gentoo, FWIW)


More information about the erlang-questions mailing list