[erlang-questions] Compiling R14B03 with hipe on Ubuntu

Kostis Sagonas kostis@REDACTED
Sun Sep 11 11:28:22 CEST 2011

On 09/10/11 18:20, Ahmet Nalcacioglu wrote:
> I have a 64 bit ubuntu 10.10
> I tried everything to build erlang with hipe support, to no avail.
> I tried using kerl
> KERL_CONFIGURE_OPTIONS="--enable-hipe" kerl build R14B03 r14b03_hipe
> Then I tried on a source I dowloaded using
> ./configure --enable-hipe
> I even removed the following lines in otp_build script which disables
> hipe for linux
> "
> if target_contains linux; then
> XX=`echo $* | grep -v able-hipe`
> if [ "$*" = "$XX" ]; then
> CONFIG_FLAGS="$CONFIG_FLAGS --disable-hipe"
> fi
> fi
> "
> then do a ./configure --enable-hipe
> I can't get a build with hipe enabled. I don't understand why for
> linux hipe is disabled in the first place.
> The only way I can get a hipe enabled erl is through ubuntu software
> center, which has a erlang-base-hipe module. However that is an old
> build R13.
> Can anyone help me? I tried but I don't know why simply ./configure
> --enable-hipe does not work.

I really do not understand what (you think) the problem is and more 
importantly I do not understand what it is you are doing.  Are you 
compiling from source and if so where did you get this source from.
(My advice: get it from Erlang's github repo.)

On most (all?) Linuxes, hipe is enabled by default, so you should really 
not need --enable-hipe. What is the slogan when you start the system? 
If it's something like:

   Erlang R14B0? [source] [64-bit] ...[hipe] ...

then HiPE is enabled.


More information about the erlang-questions mailing list