[erlang-questions] Compiling R14B03 with hipe on Ubuntu

Ahmet Nalcacioglu ahmet@REDACTED
Sat Sep 10 17:20:53 CEST 2011

I have a 64 bit ubuntu 10.10

I tried everything to build erlang with hipe support, to no avail.

I tried using kerl
KERL_CONFIGURE_OPTIONS="--enable-hipe" kerl build R14B03 r14b03_hipe

Then I tried on a source I dowloaded using
./configure --enable-hipe

I even removed the following lines in otp_build script which disables
hipe for linux

if target_contains linux; then
XX=`echo $* | grep -v able-hipe`
if [ "$*" = "$XX" ]; then
then do a ./configure --enable-hipe

I can't get a build with hipe enabled. I don't understand why for
linux hipe is disabled in the first place.

The only way I can get a hipe enabled erl is through ubuntu software
center, which has a erlang-base-hipe module. However that is an old
build R13.

Can anyone help me? I tried but I don't know why simply ./configure
--enable-hipe does not work.

More information about the erlang-questions mailing list