[erlang-questions] Table viewer disappearing

Kenneth Lundin kenneth.lundin@REDACTED
Mon Oct 18 15:30:45 CEST 2010


tv is a gs based application and thus depends on the gs application
which in turn depends on that you have tcl/tk installed.

Try gs:start() in the Erlang shell, what happens?

/Kenneth Erlang/OTP , Ericsson

On Mon, Oct 18, 2010 at 1:24 PM, Adrian Roe <ARoe@REDACTED> wrote:
> Apologies for a potentially environment related question, but I have been happily developing an mnesia database subsystem on an Amazon EC2 instance running Ubuntu 10.10.  As part of this I have used table viewer (tv:start()) and it has worked just fine (using NX/Nomachine & GNOME).  No idea what has changed, but now when I do tv:start(), I get a PID returned but no window displayed.  I've even reverted to machine images from when it was working but still no window spawned. Things like wx:demo() launch just fine.
> The docs around tv only talk about its start method and tv doesn’t appear to respond any messages sent to it via its PID.  Has anyone else seen this / know what on earth might be going on.
> Thanks for any suggestions
> Adrian

More information about the erlang-questions mailing list