[erlang-questions] Table viewer disappearing

Adrian Roe ARoe@REDACTED
Mon Oct 18 17:02:07 CEST 2010


That was just the ticket - the local copy of tk was corrupted.  All working now thanks :)


-----Original Message-----
From: erlang-questions@REDACTED [mailto:erlang-questions@REDACTED] On Behalf Of Kenneth Lundin
Sent: 18 October 2010 14:31
To: Adrian Roe
Cc: erlang-questions@REDACTED
Subject: Re: [erlang-questions] Table viewer disappearing


tv is a gs based application and thus depends on the gs application which in turn depends on that you have tcl/tk installed.

Try gs:start() in the Erlang shell, what happens?

/Kenneth Erlang/OTP , Ericsson

On Mon, Oct 18, 2010 at 1:24 PM, Adrian Roe <ARoe@REDACTED> wrote:
> Apologies for a potentially environment related question, but I have been happily developing an mnesia database subsystem on an Amazon EC2 instance running Ubuntu 10.10.  As part of this I have used table viewer (tv:start()) and it has worked just fine (using NX/Nomachine & GNOME).  No idea what has changed, but now when I do tv:start(), I get a PID returned but no window displayed.  I've even reverted to machine images from when it was working but still no window spawned. Things like wx:demo() launch just fine.
> The docs around tv only talk about its start method and tv doesn't appear to respond any messages sent to it via its PID.  Has anyone else seen this / know what on earth might be going on.
> Thanks for any suggestions
> Adrian

erlang-questions (at) erlang.org mailing list.
See http://www.erlang.org/faq.html
To unsubscribe; mailto:erlang-questions-unsubscribe@REDACTED

More information about the erlang-questions mailing list