escript and first target system

David Nonnenmacher dnonnenm@REDACTED
Wed Aug 19 10:50:00 CEST 2009

I add some detailled information about the error message, I got this:

*>>> ./escript a_file.escript
escript: Internal error: undef
           [{clause, ....*

I run escript command from the directory that contains the start_boot.beam
(thank you Charpi for the tip). But I had still the above error.

What's the meaning of this error message ? Maybe I need to configure
something else ?


2009/8/18 David Nonnenmacher <dnonnenm@REDACTED>

> Hello,
> I would like to know if this is possible to use escript command in the case
> of first target systems.
> I tried and failed to do it. I read
> and
> .
> I think that I catched the main idea. So I just copied the erl into the bin
> directory, and then modified the ROOTDIR (I also did all the stuff about the
> boot file), but escript failed to run with an error message about a missing
> start_clean.boot. So I copied the start_clean.boot into the bin directory
> and copied the escript exe file into the bin directory, but there was a code
> path problem.
> Just for your information, erl works fine.
> Is there a trick or something special to configure to run escript command
> using a first target system ?
> Thank you
> David

More information about the erlang-questions mailing list