[erlang-questions] inets service startup

Ingela Anderton Andin ingela@REDACTED
Thu Apr 19 11:20:10 CEST 2007

Ok, lets try to clear things up.

If you in your app-file declare a dependence on the inets application 
your application will not
be able to start if the inets application was not started first.

To run an orphaned httpd server it is enough that the inets application 
is loded, it does
not need it to be started.

Starting the inets application before starting an orphand server will 
not make the httpd server less orphaned.

Softupgrade of the inets application with an  orphand server around can 
result in different
things depending on several things:

- The orphaned server may be killed. Depends on the inets appup-file.

- The inets upgrade might fail. Depends on the inets appup-file.

- If the orphand server is hung under a supervisor in an other OTP 
application supervisor tree
    it might acctualy be upgrade. I would not recommend this though.

Serge Aleynikov wrote:
>> As you are running in embedded mode you do not have dynamic code 
>> loading and hence the inets
>> code is not loaded,  when you have not listed inets  as an 
>> application to start. That is why  you can not  start the  orphaned 
>> httpd server without starting the inets application in your scenario.
The above statement was not a  100 % correct.

> In the previously sent test example I tried adding inets to the either 
> 'applications' or 'included_applications' list in test.app and also 
> modifying test_without_inets.rel to:
> $ cat test_without_inets.rel
> {release, {"test", "1.0"}, {erts, "5.5.4"},
>   [
>     {kernel     , "2.11.4"},
>     {stdlib     , "1.14.4"},
>     {sasl       , "2.1.5"},
>     {inets      , "4.7.11", load},
>     {test       , "1.0"}
>   ]
> }.
> Though this still doesn't start the test application, and trying to do 
> so manually results in:
> $ make run2
> ...
> Eshell V5.5.4  (abort with ^G)
> 1> application:start(test).
> {error,{not_started,inets}}
> From what you are saying I derive that the test application should get 
> started.  What am I doing wrong then?

Hope that it is clearer now!

Regars Ingela

More information about the erlang-questions mailing list