[erlang-questions] inets service startup

Serge Aleynikov serge@REDACTED
Mon Apr 16 15:47:12 CEST 2007

> As you are running in embedded mode you do not have dynamic code loading 
> and hence the inets
> code is not loaded,  when you have not listed inets  as an application 
> to start. That is why  you can not  start the  orphaned httpd server 
> without starting the inets application in your scenario.

In the previously sent test example I tried adding inets to the either 
'applications' or 'included_applications' list in test.app and also 
modifying test_without_inets.rel to:

$ cat test_without_inets.rel
{release, {"test", "1.0"}, {erts, "5.5.4"},
     {kernel     , "2.11.4"},
     {stdlib     , "1.14.4"},
     {sasl       , "2.1.5"},
     {inets      , "4.7.11", load},
     {test       , "1.0"}

Though this still doesn't start the test application, and trying to do 
so manually results in:

$ make run2
Eshell V5.5.4  (abort with ^G)
1> application:start(test).

 From what you are saying I derive that the test application should get 
started.  What am I doing wrong then?



More information about the erlang-questions mailing list