OTP 24.0 has been released

Luke Bakken luke@REDACTED
Wed May 12 16:57:16 CEST 2021

Hi Frank,

I see the same error on my OS X system -

$ sw_vers
ProductName: macOS
ProductVersion: 11.3
BuildVersion: 20E232

May I suggest reporting it here as it appears to be a legitimate bug?


FWIW, here are the flags I pass to the top-level configure script
(using asdf/kerl):

--disable-hipe --disable-sctp --with-microstate-accounting=extra
--enable-darwin-64bit --enable-dynamic-ssl-lib --enable-kernel-poll
--enable-sctp --enable-shared-zlib --enable-smp-support
--enable-threads --enable-wx --with-ssl=$(brew --prefix openssl)
--without-docs --without-javac

Note that "--disable-sctp" does not appear to have the desired effect
during the configure stage.

I also tried downgrading autoconf to version 2.69 (from 2.71) but
still see the same error. I also tried running "autoupdate" on all of
the configure.in scripts first, but that just resulted in more errors.


On Wed, May 12, 2021 at 7:29 AM Frank Muller <frank.muller.erl@REDACTED> wrote:
> Well done guys.
> I’m getting an error about a missing 'netinet/sctp.h’ header.
> $ sw_vers
> ProductName:    macOS
> ProductVersion: 11.2.3
> BuildVersion:   20D91
> $ kerl build git https://github.com/erlang/otp.git OTP-24.0 24.0
> Checking out Erlang/OTP git repository from https://github.com/erlang/otp.git...
> Building Erlang/OTP 24.0 from git, please wait...
> Configure failed.
> checking for getrusage... yes
> checking for sys/event.h... yes
> checking for sys/epoll.h... no
> checking for sys/devpoll.h... no
> checking for sys/timerfd.h... no
> checking for netpacket/packet.h... no
> checking for netinet/sctp.h... no
> configure: error: sctp support requested, but cannot be enabled since 'netinet/sctp.h' is missing
> ERROR: /Users/frank/.kerl/builds/24.0/otp_src_git/erts/configure failed!
> ./configure: line 362: kill: (-67762) - No such process

More information about the erlang-questions mailing list