[erlang-questions] ErlIDE on Mac OS X Mavericks - anyone using it successfully?

Luca Finzi Contini <>
Sun Nov 9 17:54:41 CET 2014


Hi all,
for those of you interested in this subject, and thanks to the help of Vlad
(), I came up with a solution to work on my Macbook Pro.

Root cause was: Java 8!
Switching to Java 7 magically solved all the issues.
Here is what I did in detail.

0) my machine's 'name' is 'legolas'.
1) in System Preferences, it is displayed as "Computer Name: legolas" but
underneath this, it reads: "Computers on your local network can access your
computer at : *legolas.local*".
So I changed the hostname to be this fully qualified name:

legolas:~ finzic$ sudo hostname -s legolas.local
legolas:~ finzic$ hostname
legolas.local

2) I modified the /etc/hosts to include *legolas* and *legolas.local* on
the same line as 127.0.0.1
Looking at the log files, it seems that both the short-name and the
long-name version are needed to have it working.

3) Most importantly I found that the default JDK used was 1.8.0, so I set
JAVA_HOME to the 1.7.0 folder and launched Eclipse via terminal:

legolas:MacOS finzic$ /usr/libexec/java_home -V

Matching Java Virtual Machines (4):

    1.8.0_05, x86_64: "Java SE 8"
/Library/Java/JavaVirtualMachines/jdk1.8.0_05.jdk/Contents/Home

    1.7.0_55, x86_64: "Java SE 7"
/Library/Java/JavaVirtualMachines/jdk1.7.0_55.jdk/Contents/Home

    1.6.0_65-b14-462, x86_64: "Java SE 6"
/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

    1.6.0_65-b14-462, i386: "Java SE 6"
/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home


/Library/Java/JavaVirtualMachines/jdk1.8.0_05.jdk/Contents/Home

legolas:MacOS finzic$ echo $JAVA_HOME

/Library/Java/JavaVirtualMachines/jdk1.7.0_55.jdk/Contents/Home

legolas:MacOS finzic$

This way, everything worked extra-smoothly.
This means that all the issues of timeouts in communication between Java
and Erlang in my opinion were caused by Eclipse running Java 8.

Thank to Vlad once more for all the help.
Luca.

2014-11-05 10:58 GMT+01:00 Luca Finzi Contini <>:

> Hi all,
> is there anyone using ErlIDE / Eclipse on Mac OS X Mavericks?
> I have successfully installed it on Windows but I usually work on a Mac.
> I tried with Eclipse 3.7, 4.2.2, 4.4, with no luck.
> The IDE goes 'not responding' after a few keystrokes on the source editor.
> In the rare moments of awakens it has *wonderful* hot code update features
> which are really good especially for those accustomed to Eclipse in the
> Java world.
> I tried to follow the suggestions here:
>
> https://github.com/erlide/erlide/wiki/Troubleshooting
>
> especially when it says:
> "For Macs, an alternative solution is to rename your computer from
> foo.whatever to just foo (or anyhting without any dots)."
>
> If I do this, apparently I cannot start an erlang instance with long name
> as in
>
> erl -name foo
>
> The currently installed Java version is 1.8.0.
>
> Has anyone managed to have ErlIDE up and running smoothly on Mac?
> Thanks in advance.
> Luca.
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20141109/f521e344/attachment.html>


More information about the erlang-questions mailing list