[erlang-questions] ErlIDE on Mac OS X Mavericks - anyone using it successfully?

Youngkin, Rich <>
Wed Nov 5 19:15:36 CET 2014


>
> Hi all,
>
> is there anyone using ErlIDE / Eclipse on Mac OS X Mavericks?
> I have successfully installed it on Windows but I usually work on a Mac.
> I tried with Eclipse 3.7, 4.2.2, 4.4, with no luck.
> The IDE goes 'not responding' after a few keystrokes on the source editor.
> In the rare moments of awakens it has *wonderful* hot code update features
> which are really good especially for those accustomed to Eclipse in the
> Java world.
> I tried to follow the suggestions here:
> https://github.com/erlide/erlide/wiki/Troubleshooting
> especially when it says:
> "For Macs, an alternative solution is to rename your computer from
> foo.whatever to just foo (or anyhting without any dots)."
> If I do this, apparently I cannot start an erlang instance with long name
> as in
> erl -name foo
> The currently installed Java version is 1.8.0.
> Has anyone managed to have ErlIDE up and running smoothly on Mac?
> Thanks in advance.
> Luca.
>
>
Hi Luca,

I'm using it with some success. I have had problems with it locking up. If
my memory serves me correctly, it hung after I stopped a running Erlang
shell by typing q(). at the command line. It behaves better if you use the
Eclipse "stop" button to exit the shell. To unlock Eclipse, I took the
nuclear option, killed all the beam processes. This has the unfortunate
side effect of stopping ErlIDE.

I haven't put any effort in trying to get the long host name to work. I'd
be interested if anyone has any advice on how to get this to work.

All that said, I do use ErlIDE, but mostly just for the on-the-fly
compilation, syntax checking, and some local debugging.

Cheers,
Rich
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20141105/8e524d76/attachment.html>


More information about the erlang-questions mailing list