[erlang-questions] Fwd: ErlIDE on Mac OS X Mavericks - anyone using it successfully?

Luca Finzi Contini <>
Wed Nov 5 13:52:41 CET 2014


---------- Forwarded message ----------
From: Luca Finzi Contini <>
Date: 2014-11-05 13:52 GMT+01:00
Subject: Re: [erlang-questions] ErlIDE on Mac OS X Mavericks - anyone using
it successfully?
To: Vlad Dumitrescu <>


Hi Vlad, thank you so much for your availability!
I will collect all possible debug information about my config and maybe
prepare a short video of what I get when I use it so that you could
understand it better.
In order to better support you, is there any specific log file either
coming from Eclipse, ErlIde, mac itself, that would be useful for you?
Thanks in advance,
Luca.

2014-11-05 13:11 GMT+01:00 Vlad Dumitrescu <>:

> Hi Luca,
>
> Yes, I know a couple of people that use erlide on OSX. All the problems
> that I heard of were related to the computer name issue. Since I don't have
> a Mac, it's difficult to give you the exact steps to fix the situation. I
> assume that you have tried all the things suggested on the wiki page?
>
> If you rename your computer to "foo", that name can't be used with -name.
> You have to use the fully qualified value -- and it has to be possible to
> resolve that name, most easily by adding the entry to .hosts.
>
> Have you added the new name (and the FQDN) to .hosts?
>
> best regards,
> Vlad
>
>
> On Wed, Nov 5, 2014 at 10:58 AM, Luca Finzi Contini <
> > wrote:
>
>> Hi all,
>> is there anyone using ErlIDE / Eclipse on Mac OS X Mavericks?
>> I have successfully installed it on Windows but I usually work on a Mac.
>> I tried with Eclipse 3.7, 4.2.2, 4.4, with no luck.
>> The IDE goes 'not responding' after a few keystrokes on the source
>> editor.
>> In the rare moments of awakens it has *wonderful* hot code update
>> features which are really good especially for those accustomed to Eclipse
>> in the Java world.
>> I tried to follow the suggestions here:
>>
>> https://github.com/erlide/erlide/wiki/Troubleshooting
>>
>> especially when it says:
>> "For Macs, an alternative solution is to rename your computer from
>> foo.whatever to just foo (or anyhting without any dots)."
>>
>> If I do this, apparently I cannot start an erlang instance with long name
>> as in
>>
>> erl -name foo
>>
>> The currently installed Java version is 1.8.0.
>>
>> Has anyone managed to have ErlIDE up and running smoothly on Mac?
>> Thanks in advance.
>> Luca.
>>
>>
>> _______________________________________________
>> erlang-questions mailing list
>> 
>> http://erlang.org/mailman/listinfo/erlang-questions
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20141105/49336098/attachment.html>


More information about the erlang-questions mailing list