[erlang-questions] OpenCL.framework cause my NIF library to crash

Alfredo Di Napoli <>
Fri Mar 16 11:21:52 CET 2012


On 16/mar/2012, at 11:10, Tony Rogvall wrote:

> I just tried it, and you are totally correct.
> 
> The cl nif failed to load on R15B Darwin 11.3.0.
> What Erlang release and OS/release are you using ?
> 
> /Tony
> 

Hi Tony, I'm on a Mac Os X Lion (so SDK 10.7) with the latest Erlang distribution R15B.
I suspect this isn't a problem with your bindings, though, because I'm the same guy who asked you help about OpenCL binding with NIF via email :)
I've also tried a brain-dead simple NIF application (a stupid app that performs a square of a number), compiling it from command line (so no Xcode involved :) )
The NIF works fine, until I link ANY Mac OS Framework. In my example I've ONLY linked the AppKit.framework: bare in mind that actually the NIF does not uses it in any function call!
The result? Abort trap!

So I guess this could be a Erlang VM bug, related to Mac Os Frameworks dynamic linking process.

Regards,
Alfredo



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20120316/6d7ed89d/attachment.html>


More information about the erlang-questions mailing list