[erlang-questions] Erlang/OTP R14B02 generating documentation from source problem

Lukas Larsson <>
Thu Mar 17 11:59:03 CET 2011

It seems to me like xmerl is not in the erlang install which is in your path. Check that xmerl-x.y.z is in the lib/ dir of the erlang you have in your path. or alternatively that you can load the xmerl module in a normal erlang shell.


----- Original Message -----
From: "Damian Dobroczyński" <>
Sent: Thursday, 17 March, 2011 11:51:39 GMT +01:00 Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna
Subject: [erlang-questions] Erlang/OTP R14B02 generating documentation from source problem


I downloaded, compiled and tried to "make docs" and "make install-docs".
The first went fine. The result of the latter is the following:

escript: exception error: undefined function xmerl:export_simple/2
  in function  erl_eval:do_apply/5
  in call from erl_eval:expr/5
  in call from erl_eval:exprs/5
  in call from erl_eval:local_func/5
  in call from escript:interpret/4
  in call from escript:start/1
  in call from init:start_it/1

So, I installed without docs ("make install") and then tried again. The
result was the same. So I removed all escript links and files that I had
had already (some artifacts from previous releases and such) so that I
had only fresh escript in the installation directory and a link in the
prefix (/usr/local/bin) directory. The result was the same. Can somebody
help me, please?


More information about the erlang-questions mailing list