[erlang-questions] Erlang/OTP R14B02 generating documentation from source problem

Kazuhiro Ogura <>
Mon Mar 21 08:28:22 CET 2011


Hi,

I had the same error, and after some struggles,
finally I changed the shebang line of
lib/erl_docgen/priv/bin/xref_mod_app.escript
to the absolute path to escript, and it worked.

-#!/usr/bin/env escript
+#!/usr/local/bin/escript

I don't know why it worked,
so I can't tell whether this works for you or not.

Sure I have xmlerl-x.y.z in the lib/ dir, and I can load xmerl in a
normal erlang shell.
Also what's strange is that when I manually execute the command,
(which fails complaining about exception about xmerl:export_simple/2
in the make process),
it succeeds without any errors.

(May be some envvar passed to script is doing something wrong?)

Kazuhiro Ogura

2011/3/17 Lukas Larsson <>:
> It seems to me like xmerl is not in the erlang install which is in your path. Check that xmerl-x.y.z is in the lib/ dir of the erlang you have in your path. or alternatively that you can load the xmerl module in a normal erlang shell.
>
> Lukas
>
> ----- Original Message -----
> From: "Damian Dobroczyński" <>
> To: 
> Sent: Thursday, 17 March, 2011 11:51:39 GMT +01:00 Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna
> Subject: [erlang-questions] Erlang/OTP R14B02 generating documentation from source problem
>
>
> Hi.
>
> I downloaded, compiled and tried to "make docs" and "make install-docs".
> The first went fine. The result of the latter is the following:
>
> escript: exception error: undefined function xmerl:export_simple/2
>  in function  erl_eval:do_apply/5
>  in call from erl_eval:expr/5
>  in call from erl_eval:exprs/5
>  in call from erl_eval:local_func/5
>  in call from escript:interpret/4
>  in call from escript:start/1
>  in call from init:start_it/1
>
> So, I installed without docs ("make install") and then tried again. The
> result was the same. So I removed all escript links and files that I had
> had already (some artifacts from previous releases and such) so that I
> had only fresh escript in the installation directory and a link in the
> prefix (/usr/local/bin) directory. The result was the same. Can somebody
> help me, please?
>
> D.
>
>
> ________________________________________________________________
> erlang-questions (at) erlang.org mailing list.
> See http://www.erlang.org/faq.html
> To unsubscribe; mailto:
>
>


More information about the erlang-questions mailing list