Erlang/OTP R14B02 generating documentation from source problem

Damian Dobroczyński <>
Thu Mar 17 11:51:39 CET 2011


Hi.

I downloaded, compiled and tried to "make docs" and "make install-docs".
The first went fine. The result of the latter is the following:

escript: exception error: undefined function xmerl:export_simple/2
  in function  erl_eval:do_apply/5
  in call from erl_eval:expr/5
  in call from erl_eval:exprs/5
  in call from erl_eval:local_func/5
  in call from escript:interpret/4
  in call from escript:start/1
  in call from init:start_it/1

So, I installed without docs ("make install") and then tried again. The
result was the same. So I removed all escript links and files that I had
had already (some artifacts from previous releases and such) so that I
had only fresh escript in the installation directory and a link in the
prefix (/usr/local/bin) directory. The result was the same. Can somebody
help me, please?

D.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0x0CAE3AEB.asc
Type: application/pgp-keys
Size: 5071 bytes
Desc: not available
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20110317/d0ead537/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: OpenPGP digital signature
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20110317/d0ead537/attachment-0001.bin>


More information about the erlang-questions mailing list