[erlang-questions] Re: On Windows XP (SP2): wx broken

MapAndFold <>
Fri Jul 9 03:54:56 CEST 2010


Yeah, I have tried again on R14A, and it is *almost* OK now.

But, another problem occurs:

Opening the sudoku demo, drag to resize the window, then things crash
with this message.

---------------------------------------------------------------------------------
---------------------------
Sudoku: werl.exe - Application Error
---------------------------
The instruction at "0x02292376" referenced memory at "0x00000010". The
memory could not be "read".
---------------------------------------------------------------------------------

My guest is that it seems to be related to the painting procedure of
the window. My little app which draws some graphics is also easy to
crash when resizing the window, while in wx:demo(), most of the
examples are OK (graphicsContext is easy to crash).

On Thu, Jul 8, 2010 at 3:44 PM, Dan Gudmundsson <> wrote:
> Have you with this problem tried R14A, is it working now?
>
> I found that we had upgraded Visual Studio without recompiling
> wxWidgets DLL's causing the
> wx-driver to be dependent on two different versions of the runtime DLL,
> where only the latest where installed with erlang.
>
> Thanks for locating it.
>
> /Dan
>


More information about the erlang-questions mailing list