erlide: moving on to Eclipse 3.5 and Erlang R12

Vlad Dumitrescu <>
Tue Apr 6 09:48:19 CEST 2010


Hi all,

-- Regarding Eclipse 3.5:

Last week the last users that I know of that required Eclipse 3.4 have
upgraded to 3.5. Therefore we are planning to start building against
3.5 from the next version.

If you still need 3.4 support, please let us know (possibly off this list).

Unless there are protests, from the end of April, the 3.4 version will
remain available, but will not get updated anymore. Unfortunately we
don't have resources to keep multiple development baselines alive.

-- Regarding Erlang R12:

In the same line of thought, we would like to be able to update the
minimum supported Erlang version to R12. Actually, we'd gladly skip
R12 too and only target R13, but I don't have too high hopes on that
one. It's quite painful to have to support three different versions of
Erlang (and in practice the result is that if you use R11 or R12, not
all results from the erlide tools may be 100% correct if the tool
picks the wrong release to check against  (yes, unfortunately we still
have some bugs :-)).

Please let us know if you are still stuck with R11 and use erlide.

Hopefully we may take this step at the same time as with the Eclipse version.



Thank you very much!
best regards,
Vlad


More information about the erlang-questions mailing list