[erlang-questions] yaws mixing up requests?

Francesco Cesarini (Erlang Training and Consulting) <>
Sat May 30 14:22:34 CEST 2009


Hi Christian,

a couple of years ago probably means you were running R11? Do you recall 
what version of Erlang you were using? Was the mixup happening under 
heavy load, or under normal circumstances? While it is fairly easy to 
reproduce, we are seeing the problem only under relatively high loads.

Francesco

Christian wrote:
> On Sat, May 30, 2009 at 01:05, Ulf Wiger
> <> wrote:
>   
>> Sorry if this seems like a strange question,
>> but has anyone experienced requests being mixed up when using
>> yaws?
>>     
>
> I did have a similar problem in another place: in the otp http client.
> But that was two years ago or so, before it was rewritten. Changed
> jobs since then.
>
> We were implementing a way to serve html and html page fragments into
> a customer site. Basically providing them with some live content we
> were experts in, but all served through their domains and web servers,
> using HTTP + special headers, over direct VPN connections to our data
> center.
>
> So I was making these http calls using the http client in otp, and it
> would especially mess upp decoration images from CSS. It was ugly,
> rounded corners used as backgrounds in the wrong page elements, images
> being served where page framgments should be.
>
> ________________________________________________________________
> erlang-questions mailing list. See http://www.erlang.org/faq.html
> erlang-questions (at) erlang.org
>
>   


More information about the erlang-questions mailing list