[erlang-questions] Appmon not starting under ubuntu linux

Edwin Fine <>
Sat Sep 27 21:19:55 CEST 2008


Dan,

appmon uses graphics, which need X. In Windows, graphics are built in so you
need nothing special. I assume you are not logged in as superuser.

Try the following:

$ xterm

If you see an xterm, your appmon should have worked. If you get an error
message, there are two things I can think of off the top of my head that
might not be set up correctly.

Is your DISPLAY variable set correctly? I am assuming that this is a local
Linux box and that you are not using ssh or telnet to a remote box. If you
are, that's another story.

Try setting DISPLAY as follows:

$ export DISPLAY=:0.0

Then try the xterm again. If it STILL doesn't work, there may be X authority
problems. Try this:

$ xhost +

Warning: this is a security risk, allowing any X system access to your box.
But we'll only be doing this for a moment and I assume you are behind a
firewall.

Now try xterm again. If it works, appmon should work too.

To make this work without having to open up using xhost +, Google xauth and
Xauthority and ensure you have a ~/.Xauthority file set up correctly.

Hope this helps. If you are still stuck, please post what happened above
with xterm when you try it.

On Sat, Sep 27, 2008 at 6:18 AM, Dan Rubino <>wrote:

> Hi all,
>
> I normally develop my Erlang apps under windows but this weekend am
> having a go under Linux.
>
> My apps compile and start fine however when I try and run appmon i.e.
> appmon:start().
>
> The console just hangs and doesnt open the appmon interface.
>
> I am running 5.5.5 - anyone come across this before?
>
> Thanks,
> Dan
>
> _______________________________________________
> erlang-questions mailing list
> 
> http://www.erlang.org/mailman/listinfo/erlang-questions
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20080927/a14ff86c/attachment.html>


More information about the erlang-questions mailing list