Erlang compiler bug in R10 ?

Bjorn Gustavsson <>
Mon Feb 13 09:21:38 CET 2006


You probably have a different version of ibrowse.
There IS a bug in the compiler.

/Bjorn

Michael McDaniel <> writes:

>  works ok on my Ubuntu release 5.10 box (Debian) with R10B-9
>  
>  $ pwd
>  /home/mmcdanie/misc/src/erlang/ibrowse-1.0/src
>  $ uname -r
>  2.6.12-9-386
>  $ erl -s init stop
>  Erlang (BEAM) emulator version 5.4.12 [source] [hipe]
>  
>  Eshell V5.4.12  (abort with ^G)
>  1> 
>  $ make clean
>  rm -f ../ebin/*.beam
>  $ make
>  erlc -W +warn_unused_vars +nowarn_shadow_vars +warn_unused_import -I./  -o ../ebin ibrowse.erl
>  erlc -W +warn_unused_vars +nowarn_shadow_vars +warn_unused_import -I./  -o ../ebin ibrowse_http_client.erl
>  erlc -W +warn_unused_vars +nowarn_shadow_vars +warn_unused_import -I./  -o ../ebin ibrowse_app.erlerlc -W +warn_unused_vars +nowarn_shadow_vars +warn_unused_import -I./  -o ../ebin ibrowse_sup.erlerlc -W +warn_unused_vars +nowarn_shadow_vars +warn_unused_import -I./  -o ../ebin ibrowse_lib.erlerlc -W +warn_unused_vars +nowarn_shadow_vars +warn_unused_import -I./  -o ../ebin ibrowse_test.erl
>  
>  
>  On Wed, Feb 08, 2006 at 01:38:05PM +0100, Torbjorn Tornkvist wrote:
>  > Hi,
>  > 
>  > I'm trying to compile the ibrowse application in jungerl:
>  > ----------------------------------------------------------------
>  > > make
>  > erlc -W +warn_unused_vars +nowarn_shadow_vars +warn_unused_import -I./ 
>  > -o ../ebin ibrowse.erl
>  > erlc -W +warn_unused_vars +nowarn_shadow_vars +warn_unused_import -I./ 
>  > -o ../ebin ibrowse_http_client.erl
>  > Function chunk_request_body/3 refers to undefined label 410
>  > ./ibrowse_http_client.erl:none: internal error in beam_dead;
>  > crash reason: {{case_clause,{'EXIT',{undefined_label,410}}},
>  >                [{compile,'-select_passes/2-anonymous-2-',2},
>  >                 {compile,'-internal_comp/4-anonymous-1-',2},
>  >                 {compile,fold_comp,3},
>  >                 {compile,internal_comp,4},
>  >                 {compile,internal,3}]}
>  > make: *** [../ebin/ibrowse_http_client.beam] Error 1
>  > ------------------------------------------------------------------
>  > 
>  > I get this result with R10B-4, R10B-8, R10B-9
>  > 
>  > But with R9C, ibrowse compiles just fine.
>  > 
>  > Cheers, Tobbe
>  > 
>  
>  -- 
>  Michael McDaniel
>  Portland, Oregon, USA
>  http://autosys.us
>  +1 503 283 5284
> 

-- 
Björn Gustavsson, Erlang/OTP, Ericsson AB



More information about the erlang-questions mailing list