Undefined referrences in ttsl_drv.c

Your Control-IT Team <>
Fri May 10 22:47:39 CEST 2002


Hi Kent Boortz


>So my guess is that you need to install "libncurses.so" or similar,

Thanks a lot for your recommendation! It worked marvelously :-))
I installed something called "ncurses-devel" in SuSE 8.0
(described as "includes the development tools, headers
and static libraries for the New curses (ncurses)"),
erased the OTP R8B-1 subdirectories (just in case),
and ran "./configure" again (without stating any options).
Then I ran "make". It worked like a charme :-))
I tested the result with "bin/erl" and here was the Eshell V5.1.1

"make install" then ran without problems as well.


Have a nice weekend + cu on the bit stream
Thanks to Costel Vrinceanu for his tips as well!

Bernie



-----Original Message-----
From: Kent Boortz <>
To: Your Control-IT Team <>
Cc:  <>
Date: Freitag, 10. Mai 2002 18:30
Subject: Re: Undefined referrences in ttsl_drv.c


>
>"Your Control-IT Team" <> writes:
>> "make" (being done as root) resulted in a lot of errors reading like:
>> ...erts/emulator/drivers/unix/ttsl_drv.c "undefined reference to tgetent"
>> dito undefined reference to tgetnum, tgetflag, tgetstr, etc.
>
>There is a configure test that is less than perfect that looks for a
>library where those functions are located. If no library was found the
>configure script should terminate with an error report but it does
>not.
>
>  AC_CHECK_LIB(termlib, tgetent)
>  if test $ac_cv_lib_termlib_tgetent = no ; then
>    AC_CHECK_LIB(curses, tgetent)
>    if test $ac_cv_lib_curses_tgetent = no ; then
>      AC_CHECK_LIB(ncurses, tgetent)
>      if test $ac_cv_lib_ncurses_tgetent = no ; then
>        AC_CHECK_LIB(termcap, tgetent)
>      fi
>    fi
>  fi
>
>So my guess is that you need to install "libncurses.so" or similar,
>remove the "config.cache" file and run ./configure again. I don't know
>if this solves all your build problems but hopefully it solves some,
>
>kent
>




More information about the erlang-questions mailing list