starting erlang on remote node

Garry Hodgson <>
Thu Apr 4 22:35:40 CEST 2002


Vladimir Sekissov wrote:
> Garry Hodgson <> wrote:
> 
> garry> i'm writing some oam scripts to enable users to remotely start up
> garry> erlang on various nodes in our linux clusters.  i'm attempting to use
> garry> ssh for this, and getting some errors i don't understand.  in
> garry> particular,
> garry> when i run:
> garry>
> garry>     ssh node0 erl -setcookie cookie -name node -pa $FATHOM/lib -run
> garry> master checkin
> garry>
> garry> i get:
> garry>
> garry>    Eshell V5.0.1  (abort with ^G)
> garry>    ()1>
> garry>    =ERROR REPORT==== 4-Apr-2002::14:09:48 ===
> garry>    ** System running to use fully qualified hostnames **
> garry>    ** Hostname kestrel is illegal **
> garry>    ()1>
> garry>
> garry> and no response to anything i type at this command prompt. the
> garry> master:checkin()
> garry> from the "-run" arg does not appear to get run.  hitting ^C gets me:
> garry>
> garry>    Killed by signal 2.
> 
> Your shell on remote host is not interactive.
> So you can't interact with your program.

i realized after i posted that i can, indeed, type at the erlang
shell and run commands.  the error above is coming from the
master:checkin()
call implied by the -run flag.  if i run it by hand at the prompt i get,
the same error appears, even though the nodename appears correct:

()2> master:checkin().
 
=ERROR REPORT==== 4-Apr-2002::15:33:19 ===
** System running to use fully qualified hostnames **
** Hostname kestrel is illegal **
{checkin,''}
()3> node().
''
                                                             
-- 
Garry Hodgson                   Let my inspiration flow
Senior Hacker                      in token rhyme suggesting rhythm
Software Innovation Services    that will not forsake me
AT&T Labs                          'til my tale is told and done.




More information about the erlang-questions mailing list