[erlang-questions] Problem building plt to dialyzer

Kelly McLaughlin mclaughlin77@REDACTED
Thu Jan 26 20:27:05 CET 2017

I'm having some issues that seem related to your problem. I don't have a
good solution for you, but I'll add some details about my problems to the

I'm running Arch Linux and I I've been using erlang 18.3 from a custom
build instead of the Arch package. As of about a month ago, everything was
fine including dialyzer and xref. I didn't do any work with erlang for
about a month and went back to it this week and found that I could no
longer get dialyzer or xref to work. I get complaints about missing
debug_info like this:

===> Error in dialyzing apps: Could not get abstract code for file:
(please recompile it with +debug_info)

But the module_info disagrees that debug_info is not present:

1> beam_disasm:module_info().
              {author,"Kostis Sagonas"}]},




Meanwhile our build machine running Debian 8 and also using erlang 18.3 is
still able to run dialyzer just fine. This makes me think it's likely an
issue with a system package that may have advanced on Arch and included
some changes that cause this problem.

I've tried other versions of erlang as well with the same results. I
unpacked some versions of 18.3 from the esl debian packages and using them
got the same debug_info error. I wiped out my 18.3 PLT files trying to get
things working, but I still had some 18.2.1 PLT files. I built a version of
18.2.1, but dialyzer thinks the files are invalid and if I move them out of
the way then I am back to the debug_info errors.

1> dialyzer:plt_info("rebar3_18.2.1_plt").

If I copy that same PLT file to our Debian build machine and do the same
the file seems fine:

1> dialyzer:plt_info("rebar3_18.2.1_plt").





Any thoughts or ideas on this are appreciated. Thanks!

> I've installed erlang 19.2 from source code on my Gentoo Linux and I'm not
> able to build plt to dialyzer. It gives me the above error. The build was
> configured with --without-javac --prefix=/usr
> dialyzer --build_plt --apps kernel
> dialyzer: Could not get abstract code for file:
> /usr/lib/erlang/lib/kernel-5.1.1/ebin/disk_log.beam (please recompile it
> with +debug_info)
> I've also tried entering on erts/emulator and running make debug and tried
> to set ERL_COMPILE_FLAGS="+debug_info" with no luck.
> I don't know if it is an issue with gentoo (both my gentoo machines have
> the same problem) because I have the same issue using portage and evm to
> install it.
> Thank you!
> --
> Michel Almada de Castro Boaventura
> Analista de Sistemas
> Laborat?rio de Software Livre - LSL
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <
> http://erlang.org/pipermail/erlang-questions/attachments/20170116/6d5b2792/attachment-0001.html
> >
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20170126/37a110d4/attachment.htm>

More information about the erlang-questions mailing list