[erlang-questions] Port of Erlang (19.2) on AIX

Kostis Sagonas kostis@REDACTED
Mon Jan 16 22:25:20 CET 2017

On 01/16/2017 05:12 PM, REIX, Tony wrote:
> After building with Hipe, I've tried without Hipe.
> And I got the same result: an infinite loop, in read() from
> signal_dispatcher_thread_func().
>   In: ERLC   ../ebin/hipe_rtl.beam              with Hipe (--enable-hipe)
>   In: ERLC   ../ebin/hipe_consttab.beam   without Hipe (--disable-hipe)
> . No idea why "hipe" appears here also.
> So, for now, I have a common issue, with or without hipe.

I can provide some info regarding the behavior you are experiencing:

  - Certain modules of the 'hipe' application, though not all. are 
compiled independently of whether HiPE is enabled or not because they 
are used by 'dialyzer'.

  - It just so happens that 'hipe' is the first application that is 
compiled in the bootstrapping process, so the infinite loop you are 
getting is not related to HiPE but shows some deeper problem in the 
system you have built.

Bottomline: what you are experiencing is not HiPE-related.  Your system 
is broken.


More information about the erlang-questions mailing list