[erlang-questions] Can't make dirty schedulers work on a certain VPS

Steve Vinoski vinoski@REDACTED
Mon Aug 15 01:08:01 CEST 2016

On Sun, Aug 14, 2016 at 6:38 PM, John Doe <donpedrothird@REDACTED> wrote:

> Hi all,
> got a very strange problem today on a Debian 7.11, gcc 4.7.2  VPS - all
> apps with dirty schedulers nifs fail with  "{error, {bad_lib, xxx requires
> a runtime with dirty scheduler support."}}"
> The erlang is built by
> KERL_CONFIGURE_OPTIONS="--disable-dynamic-ssl-lib  --with-ssl=/usr/
> --enable-smp-support  --without-termcap --enable-dirty-schedulers
> --enable-builtin-zlib" ./kerl build git https://github.com/erlang/otp.git
> OTP-19.0.4 OTP-19.0.4
> This is not problem of the apps, all the apps fail with the same error, I
> tried https://github.com/vinoski/bitwise and a couple of other.
> There are no problems altogether with the same apps and the same OTP built
> with the same command on my home box. Anyway, i tried to build erlang with
> other flags and with no kerl, nothing changed.
> What could be the reason for that?

I think the only way you can get that error message is if the runtime is
not actually compiled with dirty schedulers enabled. Are you sure you're
picking up the right runtime via your path? When you start an erlang shell,
does the status line include something like

    [smp:8:8] [ds:8:8:10]

or is the "ds" part missing? What do you get if you execute the following
in the erlang shell?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20160814/bb0909d2/attachment.htm>

More information about the erlang-questions mailing list