[erlang-questions] Can't make dirty schedulers work on a certain VPS

John Doe donpedrothird@REDACTED
Mon Aug 15 00:38:21 CEST 2016

Hi all,
got a very strange problem today on a Debian 7.11, gcc 4.7.2  VPS - all
apps with dirty schedulers nifs fail with  "{error, {bad_lib, xxx requires
a runtime with dirty scheduler support."}}"

The erlang is built by
KERL_CONFIGURE_OPTIONS="--disable-dynamic-ssl-lib  --with-ssl=/usr/
--enable-smp-support  --without-termcap --enable-dirty-schedulers
--enable-builtin-zlib" ./kerl build git https://github.com/erlang/otp.git
OTP-19.0.4 OTP-19.0.4

This is not problem of the apps, all the apps fail with the same error, I
tried https://github.com/vinoski/bitwise and a couple of other.

There are no problems altogether with the same apps and the same OTP built
with the same command on my home box. Anyway, i tried to build erlang with
other flags and with no kerl, nothing changed.

What could be the reason for that?
I can give root ssh to the VPS if anyone interested.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20160815/3707bffd/attachment.htm>

More information about the erlang-questions mailing list