[erlang-questions] xref: adding directories dinamically

Oscar Felipe groovenino@REDACTED
Tue Apr 15 13:42:10 CEST 2014

Hi All,
I can successfully import the dependencies I need in my node importing them
manually with -pa as following:
erl -pa ebin deps/*/ebin /path/to/release/*/ebin

Then I start xref and add a release without errors.

Whereas when I start a node and try to add the path in this way :
Libs = filelib:wildcard("/path/to/release/*/ebin"),
Deps = filelib:wildcard("deps/*/ebin"),
code:add_pathsa(Libs ++ Deps)

This does not work, despite that file:get_cwd() gives the same result as
when I load the libraries manually including the paths with -pa flag.
After that I also tried to add the directories to xref without success:

[xref:add_directory(xr,D) || D <- Libs ++ Deps].

What do I am missing to provide all the paths that xref needs to start?
I really appreciate any help you can provide,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20140415/e0272d5e/attachment.htm>

More information about the erlang-questions mailing list