[erlang-questions] Crash during compilation

Anthony Ramine n.oxyde@REDACTED
Tue Oct 15 10:25:02 CEST 2013


Is your module quite large and uses a lot of binary patterns?

Try erlc +time.

Anthony Ramine

Le 15 oct. 2013 à 09:27, Maruthavanan Subbarayan <maruthavanan_s@REDACTED> a écrit :

> Hi,
> I am receiving and crash dump during compilation of my code, stating could not allocate memory and takes a lot time. I am able to compile other bigger modules in same environment. I passed and "-v" to put verbose of "erlc" but I could not see any output.
> Slogan: eheap_alloc: Cannot allocate 1098556536 bytes of memory (of type "heap").
> System version: Erlang R16B02 (erts-5.10.3) [source] [64-bit] [async-threads:10] [hipe] [kernel-poll:false]
> I tried 'rebar" as well as "erlc"  how can I get more information? I am wondering what area of my code causes heap to grow during compilation? Any ideas?
> One more interesting fact is, one of the modules which was not changed is also facing this problem suddenly. I also tried copying the folder to Erlang-R14B04, and this also had same problem now. How should I proceed further? 
> Thanks,
> Marutha
> _______________________________________________
> erlang-questions mailing list
> erlang-questions@REDACTED
> http://erlang.org/mailman/listinfo/erlang-questions

More information about the erlang-questions mailing list