[erlang-questions] Crash during compilation

Maruthavanan Subbarayan maruthavanan_s@REDACTED
Tue Oct 15 09:27:15 CEST 2013

I am receiving and crash dump during compilation of my code, stating could not allocate memory and takes a lot time. I am able to compile other bigger modules in same environment. I passed and "-v" to put verbose of "erlc" but I could not see any output.
Slogan: eheap_alloc: Cannot allocate 1098556536 bytes of memory (of type "heap").System version: Erlang R16B02 (erts-5.10.3) [source] [64-bit] [async-threads:10] [hipe] [kernel-poll:false]
I tried 'rebar" as well as "erlc"  how can I get more information? I am wondering what area of my code causes heap to grow during compilation? Any ideas?
One more interesting fact is, one of the modules which was not changed is also facing this problem suddenly. I also tried copying the folder to Erlang-R14B04, and this also had same problem now. How should I proceed further? 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20131015/14f22971/attachment.htm>

More information about the erlang-questions mailing list