[erlang-questions] install problem - wxwidgets, R15B03 - solved, sort of

Miles Fidelman mfidelman@REDACTED
Sun Jan 13 07:06:50 CET 2013

Just installed R15B03 on Debian Squeeze.  Ran into lots of problems 
getting wxwidgets to configure.  I don't think I'm alone in this, 
googling for solutions, I found a number of other folks who got stuck on 

After digging through ../lib/wx/config.log, I discovered some 
interesting things:

1.  First, I was getting  errors about there not being a working copy of 
wxwidgets. Turns out, that when building wxWidgets, from source, one has to:

./configure --enable-unicode

and, after make; make install, I think it's necessary to:


(not sure, the wxwidget build instructions are equivocal on this, after 
multiple tries, I'm no longer sure whether this step was necessary or not)

2. Once past that, I started getting warnings about not being able to 
link to wxwidgets, and looking in the logs, I found an error about not 
being able to find wx/stc/stc.h.

Turns out that configure was looking in /usr/local/include/wx, but...
the make install was putting the file under /usr/local/include/wx-2.8/

The simple fix was to do:

ln -s /usr/local/include/wx-2.8/ /usr/local/include/wx

After which configure found everything, and make worked just fine.

I'm not quite wise enough in the ways of Autoconf to tell if this is a bug in ../lib/wx/configure.in,
or if it's a bug in in the Makefile for wxwidgets (though ../lib/wx/configure.in is smart enough to find gtk
files that are under ../gtk-2.0/...., so....

Figure this might be useful to folks.

Miles Fidelman wrote:
> Hi Folks,
> I'm installing R15B03 on Debian Squeeze.  I've managed to resolve all 
> the dependency issues EXCEPT:
> wxWidgets not found, wx will NOT be usable
> I've tried:
> - installing wxWidgets-2.8.12 from source, and
> - installing the debian packages of
> libwxgtk2.8-dev libgtk2.0-dev
> from apt.wxwidgets.org
> - installed the erlang-wx package from the debian repo (the only thing 
> not installed by the above)
> And finally, per the directions in the ./config output, stating:
>         Please check that wx-config is in path, the directory
>         where wxWidgets libraries are installed (returned by
>         'wx-config --libs' or 'wx-config --static --libs' command)
>         is in LD_LIBRARY_PATH or equivalent variable and
>         wxWidgets version is 2.8.4 or above.
> # which wx-config
> /usr/local/bin/wx-config
> # wx-config --libs
> -L/usr/local/lib -pthread   -lwx_gtk2_richtext-2.8 -lwx_gtk2_aui-2.8 
> -lwx_gtk2_xrc-2.8 -lwx_gtk2_qa-2.8 -lwx_gtk2_html-2.8 
> -lwx_gtk2_adv-2.8 -lwx_gtk2_core-2.8 -lwx_base_xml-2.8 
> -lwx_base_net-2.8 -lwx_base-2.8
> /usr/local/lib
> configure still gives the "not found" error
> a lot of googling tells me at least a few other folks have this as 
> their last remaining install problem, as well.
> Not really essential for my purposes, but still... is this a bug, or 
> am I missing something?
> Any suggestions?
> Thanks!
> Miles Fidelman

In theory, there is no difference between theory and practice.
In practice, there is.   .... Yogi Berra

More information about the erlang-questions mailing list