[erlang-questions] Install win64 r15B02 on Windows 2012 server issues

Patrik Nyblom pan@REDACTED
Fri Nov 9 15:32:53 CET 2012

On 11/08/2012 07:36 PM, Mark Ward wrote:
> Hi Patrik,
> It looks like the installer does not install the vcredist x64 2010 
> version and fails to detect it correctly.  After I downloaded the 
> vcredist x64 2010 and installed it the erlan win64 installation 
> worked.  I see the bin directory!  Plus the app that uses erlang is 
> working with the erlang win64 installed.
RIght - we probably need to update the vcredist shipped to a newer 
version then. I'll look into that for the R15B03 release. I think I have 
enough information to reproduce, just need to set up a blank 2012 server 
to test on... sigh...

I'll get back to you if I have problems reproducing!
> Let me know if there is further testing I can provide.  I have the log 
> files that I will continue to send to you.
> -Mark
Thanks for the report and the help!

> On Thu, Nov 8, 2012 at 12:01 PM, Patrik Nyblom <pan@REDACTED 
> <mailto:pan@REDACTED>> wrote:
>     Hi!
>     Actually Win 2012 should already have the libraries installed, I
>     wonder what's wrong...
>     Could you try installing the vcredist manually (download from
>     http://www.microsoft.com/en-us/download/details.aspx?id=14632) and
>     see if anything gets better?
>     The bin directory not being populated indicates that Install.exe
>     in the top erlang installation dir could not be run. Could you
>     also try to run that from a command line and see if it says
>     something interesting (like "i cannot find the dll's, i'm a very
>     sad windows exe" or something...). It gets run by the installer at
>     the end to copy some files, it may be silent if it fails to start...
>     When installing, you get a log window (that you can see if
>     clicking the "Show details" button when files are expanded). If
>     you run the x64 installation, with documentation unchecked, klick
>     show details, wait until the installation is done, then rightclick
>     the log and select "Copy details to clipboard", you can then paste
>     the log in a mail and send it to me (pan@REDACTED
>     <mailto:pan@REDACTED>). If we're lucky, it might contain a hint
>     about why Install.exe is not run or what happens to the x64
>     vcredist installer.
>     Cheers,
>     /Patrik
>     On 11/08/2012 06:39 PM, Mark Ward wrote:
>>     Hello,
>>     I have a freshly created Windows 2012 x64 server with GUI.  The
>>     first application to install was erlang.  It appears the win64
>>     installer fails to install all of the files required for erlang
>>     OTP R15B02.  The win32 installer works.
>>     I am using the otp_win64_R15B02_with_MSVCR100_installer_fix.exe
>>     installer and the 32bit version.  Below is more details about
>>     what happened.
>>     1. Ran otp_win64_R15B02_with_MSVCR100_installer_fix.exe as
>>     administrator.  It found the C runtime library was not installed
>>     but it didn't prompt or run the installer for the c runtime
>>     library.  The installer continued without error.  The path
>>     "c:\program files\erl5.9.2 exists but the sub folder "bin" did
>>     not exist.  It appears the win64 installer didn't install all files.
>>     2. Uninstalled win64.  No errors given during uninstallation.
>>     3. Ran otp_win32_R15B02_with_MSVCR100_installer_fix.exe as
>>     administrator.  It found the c runtime library was not installed.
>>      It prompted and installed the runtime and the rest of the
>>     installer went without error.  The win32 version worked.
>>     Thinking the c runtime library installation was the issue...
>>     4. Uninstalled win32.  No errors given during uninstallation
>>     5.  Ran otp_win64_R15B02_with_MSVCR100_installer_fix.exe as
>>     administrator.  The installer detected the C runtime library was
>>     already installed and had it unchecked in the installer.  The
>>     installer then ran and gave no errors.  The path "c:\program
>>     files\erl5.9.2 didn't contain the "bin" folder.  The win64 was
>>     incomplete.
>>     Since then I have reinstalled the win32.
>>     So far the issues with the installation of the win64 is
>>     repeatable.  Please let me know if there is anything I can do to
>>     further help identify if this is a real issue.
>>     -Mark
>>     _______________________________________________
>>     erlang-questions mailing list
>>     erlang-questions@REDACTED  <mailto:erlang-questions@REDACTED>
>>     http://erlang.org/mailman/listinfo/erlang-questions
>     _______________________________________________
>     erlang-questions mailing list
>     erlang-questions@REDACTED <mailto:erlang-questions@REDACTED>
>     http://erlang.org/mailman/listinfo/erlang-questions

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20121109/5d24f3ff/attachment.htm>

More information about the erlang-questions mailing list