[erlang-questions] If you could rename ports, what would you call them?

Masklinn masklinn@REDACTED
Tue Oct 5 11:02:33 CEST 2010

On 2010-10-05, at 10:34 , Joe Armstrong wrote:
> Pids
> There shouldn't be ports in the language at all (sorry) - ports should
> in all circumstances
> behave and be indistinguishable from Pids.  open_port(...) should
> return a Pid and not a port.
> We should reduce the number of concepts in the langauge not increase
> them - all in the
> name of conceptual integrity.
> /Joe

But they *are* two different concepts. Even if at the usage level they behave the same way from the POV of an external process, they're not created the same way (``open_port`` vs ``spawn`` and a bunch of control functions dumped into the ``erlang`` module), and you also need to distinguish them when *implementing* them. And I'm guessing that's where Tony is looking for a better name.

If down the line ports and pids are better merged (in both external interface and implementation details) then maybe "ports" as a name/concept can disappear, but I don't think that's the case at the moment, you still need to refer to them as entities separate from pids when talking about implementing things in erlang.

More information about the erlang-questions mailing list