[erlang-questions] If you could rename ports, what would you call them?
Tue Oct 5 10:34:35 CEST 2010
There shouldn't be ports in the language at all (sorry) - ports should
in all circumstances
behave and be indistinguishable from Pids. open_port(...) should
return a Pid and not a port.
We should reduce the number of concepts in the langauge not increase
them - all in the
name of conceptual integrity.
On Tue, Oct 5, 2010 at 6:45 AM, Tony Arcieri <tony.arcieri@REDACTED> wrote:
> I'm working on Reia, a Ruby-like language for the Erlang VM. Reia is an
> everything-is-an-object language, and the Erlang core types are all wrapped
> as objects.
> As part of this process I've wrapped ports. However, in my opinion port is a
> confusing name, particularly when dealing with a TCP port (in the Erlang
> sense) which represents a connection to a particular TCP port (in the TCP
> Because of this sort of ambiguity, I'd like to rename ports. But what's a
> good replacement name? Some of the ones I've considered: SysPort, IOPort,
> What would you call ports if you had the opportunity to rename them?
> Tony Arcieri
> Medioh! A Kudelski Brand
More information about the erlang-questions