[erlang-questions] hipe_bifs missing in R13B02

Dmitry Belyaev rumata-estor@REDACTED
Fri Nov 13 14:07:37 CET 2009

I was trying to build on Ubuntu 9.10 64bit.

I followed instructions but found there was no [hipe] in erlang prompt.
Tried to compile many times and yes, each beggining with freshly
unpacked tarball.

First, I found that "./configure --disable-threads && make" makes erl
with hipe but without async threads.

Next, I tried to "make clean" but it doesn't work on "freshly unpacked
tarball". But "./configure && make clean && ./configure && make"" works
fine with everything enabled.

On Fri, 2009-11-13 at 13:26 +0100, Mikael Pettersson wrote:
> Dmitry Belyaev writes:
>  > And as we discovered yesterday current R13B02-1 source package requires
>  > 'make clean' to build with hipe-support.
> If it does then it's either a dirty source package or a problem with your
> environment or build process. I just downloaded otp_src_R13B02-1.tar.gz
> from erlang.org to an x86 box running CentOS 5.3, and it built just fine
> with --enable-hipe.
> You did the ./configure and make in a pristine directory from a freshly
> unpacked tarball, right? If not, then 'make clean' is probably required,
> but that's not a HiPE bug.
> ________________________________________________________________
> erlang-questions mailing list. See http://www.erlang.org/faq.html
> erlang-questions (at) erlang.org

More information about the erlang-questions mailing list