[erlang-questions] Cannot compile file using CEAN distribution

Ashok P. Nadkarni apnadkarni@REDACTED
Wed Mar 7 06:14:26 CET 2007

I'm just starting on learning Erlang so apologies in advance if this 
question has an obvious answer. (BTW, is there a separate mailing list 
for novices?)

Platform is Windows XP.

I wrote a simple module x.erl. When I compile it from the werl that 
comes in the R11B3 distribution using "c(x).", everything works fine. 
However, when I try to compile the file from the werl that comes with 
the CEAN distribution, I get the following error:

4> c(x).

=ERROR REPORT==== 7-Mar-2007::10:34:06 ===
Error in process <0.31.0> with exit value: 

** exited: {undef,[{compile,file,[x,[report_errors,report_warnings]]},
                   {shell,eval_loop,3}]} **

I assume this means the compile module was not found? cean:installed() shows


I tried cean:install(compile) but that shows no such package. I tried 
cean:install(compiler) but that generates the error "hipe package" not 
found (or some such).

What am I doing wrong with CEAN? I would have thought the CEAN werl and 
the R11B werl would exhibit the same behaviour.



More information about the erlang-questions mailing list