Getting Started: tut.erl : exiting with an error?!?

Matthias Lang matthias@REDACTED
Fri Jan 14 09:02:10 CET 2005

Charles Hixson writes:

 > :~/projects/erlang$ erl
 > Erlang (BEAM) emulator version [source] [hipe] [threads:0]
 > Eshell V5.3.6.3  (abort with ^G)
 > 1> c(tut).
 > ** exited: {undef,[{compile,file,[tut,[report_errors,report_warnings]]},
 >                    {c,c,2},
 >                    {erl_eval,do_apply,5},
 >                    {shell,eval_loop,2}]} **

 > I'm so much of a beginner that I can't guess what is happening...but I 
 > think it's my system rather than the program.  I have erlang installed 
 > from the Debian archives... so that should be a pretty good version.  

Yup, your Erlang installation is broken. Here's what the same operation
looks like on a working system:

   | tmp >erl
   | Erlang (BEAM) emulator version [source] [hipe]
   | Eshell V5.3.6.3  (abort with ^G)
   | 1> c(tut).
   | {ok,tut}

I normally use Erlang compiled from source, but just to check your
problem, I tried installing the current Erlang from unstable. It
worked, but it's a different version to the one you're running. 

Suggestion: try the Erlang from unstable. If it still doesn't work,
install Erlang from the source code on the website. It's
actually quite easy: you just untar it and run configure and then
make. You don't even have to run 'make install' if you don't want
to---you can run it from the directory you compiled in. Takes quite
some time to compile, though.


More information about the erlang-questions mailing list