odbc problem

Ingela Anderton ingela@REDACTED
Tue Apr 5 09:22:41 CEST 2005

Anders Nygren wrote:
> Hi 
> I am trying to use odbc and have run into a strange problem.
> Using R10B-2 on Windows XP, with Microsoft SQL Server2000.
> The data is inserted in the table on the sql server but for some
> reason the connection is lost.
Well you must be the first one that tried to use parameterized queries
on a windows platform. Our automated test cases for parameterized
queries have failed on windows for some time (works fine on solaris),
but before I wrote the new configure script I could not reproduce the
fault. When I built only the odbc application the old way it always
worked. Now I can reproduce it but if I try to debug compile it to
get some more information it starts working again. All efforts so far
has alas led nowhere. The exit code indicates that the c function
send/4 that sends a message on a socket has failed returning -1 which
suggest something else has gone wrong and somehow messes up the input to
send. I was hoping we would have found the problem by now but as it
does not have top priority it might be time to at least document it
as an known problem!

> I have tried to trace the odbc driver with {trace_driver,on}
> but it does not look very interesting, (but what do I know),
> I have attatched it anyway.
Well thank you I am not sure it will help but I will take a look at
it you never know! A problem though is that I have many other things to
do the are higher prioritized so it might take a while before I have
time to really investigate this further.

> ** {port_exit,socket_send_message_body_failed}

/Ingela - OTP team

More information about the erlang-questions mailing list