[erlang-questions] Problems stop/attach a release

Technion <>
Tue Mar 22 01:54:12 CET 2016


Hi,

Are you by chance setting:

env ERL_EPMD_ADDRESS 127.0.0.1

?

I thought this was a good idea for security if the application is running on a single node, but with rebar3, it just generates the exact issue you describe below.

________________________________________
From:  <> on behalf of Khitai Pang <>
Sent: Monday, 21 March 2016 8:51 PM
To: Erlang
Subject: [erlang-questions] Problems stop/attach a release

Hi,

I build my release by erlang.mk and relx.

I can start the release by running:

$ _rel/myapp/bin/myapp start

It starts well and listens properly, I tried to use my client app to
connect to it, all functions well, and I can start other nodes, and
distribution works just fine.


Problem 1:

I can't stop it by running

$ _rel/myapp/bin/myapp stop

after running the command, it's still running (the processes are still
there).

Problem 2:

I can't start an attaching shell, when I run

$ _rel/myapp/bin/myapp attach

I get "Node is not running!"


Any idea?


Thanks
Khitai
_______________________________________________
erlang-questions mailing list

http://erlang.org/mailman/listinfo/erlang-questions


More information about the erlang-questions mailing list