[erlang-questions] Wrangler Issues - Renaming of a function fails with an error.

KuldeepSinh Chauhan chauhan.kuldeep.sinh@REDACTED
Wed Apr 20 09:16:19 CEST 2016

Renaming of a function fails, with following error.

The Wrangler application is not started, or is not working properly, please
restart the refactorer!

This is my first time experience with installing and using Wrangler. The
steps I have followed, are described below.

   1. I have Erlang 18.3 Installed on my Ubuntu 15.04.
   2. I have built and installed Wrangler, with the latest code downloaded
   from Wrangler repository on GitHub.
   3. Thus the installed version on my machine is Wrangler 1.2.0
   4. I have configured, it as mentioned in the INSTALL document, available
   in the same repository
   5. Initially, Wrangler menu did not appear in my Emacs, on pressing Cc
   Cr. Though, pressing Cc Cr started Wrangler - and I could see following
   message : (Successfully uploaded backend modules into node).
   6. In order to see Wrangler menu on Emacs, I ran following command : Mx
   wrangler-menu-init - and I was able to see wrangler menu.
   7. Following it, I customized Wragler and provided my source directory
   to .erl files.
   8. After following above steps to configure Wrangler, when I tried to
   rename a function with Wrangler, I got the error mentioned at the top.

Please let me know, if something I am missing.

Thank you,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20160420/2153213e/attachment.htm>

More information about the erlang-questions mailing list