[erlang-questions] ErlIDE on Mac OS X Mavericks - anyone using it successfully?

Luca Finzi Contini <>
Wed Nov 5 10:58:54 CET 2014


Hi all,
is there anyone using ErlIDE / Eclipse on Mac OS X Mavericks?
I have successfully installed it on Windows but I usually work on a Mac.
I tried with Eclipse 3.7, 4.2.2, 4.4, with no luck.
The IDE goes 'not responding' after a few keystrokes on the source editor.
In the rare moments of awakens it has *wonderful* hot code update features
which are really good especially for those accustomed to Eclipse in the
Java world.
I tried to follow the suggestions here:

https://github.com/erlide/erlide/wiki/Troubleshooting

especially when it says:
"For Macs, an alternative solution is to rename your computer from
foo.whatever to just foo (or anyhting without any dots)."

If I do this, apparently I cannot start an erlang instance with long name
as in

erl -name foo

The currently installed Java version is 1.8.0.

Has anyone managed to have ErlIDE up and running smoothly on Mac?
Thanks in advance.
Luca.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20141105/24013fdc/attachment.html>


More information about the erlang-questions mailing list