[erlang-questions] Erlang/OTP 17.0 and android

Erik Reitsma <>
Mon Apr 21 15:36:30 CEST 2014


Hi all,

I will update my Erlang4Android 
(https://code.google.com/p/erlang4android/) to 17.0 soon (this week, I 
hope). I have it working on my own device, I just need to add the 
interface to the Android functions from Scripting Layer for Android 
(SL4A). I want to use the $handle_undefined_function instead of hacking 
the error handler as I did with the R16 version.
Most of the work I did for Erlang4Android is included in the official 
release of 17.0, but not all (which I found out when I tried to run the 
build without modifications).

I see no need to root the device (for installing Erlang) if you use my 
installer.

Regards,
*Erik.

On 04/21/2014 12:59 PM, Dmitry Kolesnikov wrote:
> Hello,
>
> There is a HOW TO docs. They covers build procedure and release preparation. However, there is not any silver bullet for deployment into device. If you are looking OTP deployment to high-end device then you might need to root it. I managed to deploy it into device using RnD mode and adb tool. What is your target device?
>
> Best Regards,
> Dmitry
>> -|-|-(*>
>> On 21 Apr 2014, at 13:10, Benoit Chesneau <> wrote:
>>
>> Is there any doc somewhere about the recent cross-platform android build addition? How to use a builded Erlang on this platform?
>>
>> - benoit
>>
>>
>>
>> _______________________________________________
>> erlang-questions mailing list
>> 
>> http://erlang.org/mailman/listinfo/erlang-questions
> _______________________________________________
> erlang-questions mailing list
> 
> http://erlang.org/mailman/listinfo/erlang-questions




More information about the erlang-questions mailing list