[erlang-questions] wxErlang and wxWidgets 3.0

Dan Gudmundsson <>
Fri Nov 15 10:14:00 CET 2013


The intention is that is should work with both. But I only test it
occasionally.

I personally try to link against 3.0, or rather their master branch, when
doing development.

But we don't support newer functionality, and some erlang code may need to
be rewritten
to work on both 2.8 and 3.0, btw SUSE 10 and thus wxWidgets 2.6 is still
used here internally, sigh.

I have not noticed the notebook problem, don't know if that is a wxWidgets
problem or a demo problem.

Cheers


On Fri, Nov 15, 2013 at 9:46 AM, Sergei Golovan <> wrote:

> Hi!
>
> Debian GNU/Linux distribution is currently working on a replacing
> wxWidgets 2.8 by 3.0 (and subsequent removal of 2.8 next year). So,
> I'd like to ask what is the status of support for wxWidgets 3.0 in
> wxErlang?
>
> As far as I can see in configure script, it checks for >= 2.8.4. Also,
> HOWTO/INSTALL.md mentions wxWidgets only for MacOS X (>= 2.9.4 is
> required).
>
> I've tried to build wxErland using wxWidgets 3.0 and run demos. They
> seems to work fine, with the exception of a notebook with colorful
> pages. Their background is just plain grey (with 2.8 colors are fine).
>
> Cheers!
> --
> Sergei Golovan
> _______________________________________________
> erlang-questions mailing list
> 
> http://erlang.org/mailman/listinfo/erlang-questions
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20131115/d9400a8f/attachment.html>


More information about the erlang-questions mailing list