[erlang-questions] wxErlang and wxWidgets 3.0

Sergei Golovan <>
Fri Nov 15 09:46:53 CET 2013


Hi!

Debian GNU/Linux distribution is currently working on a replacing
wxWidgets 2.8 by 3.0 (and subsequent removal of 2.8 next year). So,
I'd like to ask what is the status of support for wxWidgets 3.0 in
wxErlang?

As far as I can see in configure script, it checks for >= 2.8.4. Also,
HOWTO/INSTALL.md mentions wxWidgets only for MacOS X (>= 2.9.4 is
required).

I've tried to build wxErland using wxWidgets 3.0 and run demos. They
seems to work fine, with the exception of a notebook with colorful
pages. Their background is just plain grey (with 2.8 colors are fine).

Cheers!
-- 
Sergei Golovan


More information about the erlang-questions mailing list